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Wireless Communication
Options with Arduino

Infrared

Pro’'s:
Cheap
DIY

Cons:

Directional — Must face receiver
Short range (10-meter max)
One way

Little information can be passed
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Wireless Communication
Options with Arduino

XBees/Zigbee are small low-power
digital radios.

Pros:

Multi-point networking

Mesh networks

Range: 10 to 100 meters but can be
extended by adding more devices.
Low power

Secure networking

Cons:

Need atleast 3 devices: Zigbee
coordinator, Zigbee router and end device
Expensive

Complex to configure
Workshop 8
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Wireless Communication
Options with Arduino

Radio communication

Pros:

Range: 10 to 150 meters depending on
power output and environment.

Cheap

Widely popular, so many resources online
Reliable

Can broadcast to many receivers

Cons:
Slow data rate
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Wireless Communication
Options with Arduino

Bluetooth

Pros:
Simple setup
Universal

Cons:

Can only connect 2 devices
Limited range: 10 meters max
Expensive

Size
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Wireless Communication
Options with Arduino

ESP8266 (WiFi)

Pros:

Range: Long

Cheap

Ability to connect your hardware to web-interfaces
Can connect lots of devices together (Mesh network)
Can work as router and receiver

Cons:
Can be more difficult to set up
Needs additional knowledge of web protocols
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Internet of Things
(ESP8266)
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Internet of Things

The Internet of Things (loT) refers

to a system of interrelated, internet-
connected objects that can collect
and transfer data over a wireless
network without human intervention

IAT 884 - Tangible Technology
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Internet of Things

The ESP8266 was released in late
2014. It consists out of a
microcontroller with 11 1/O pins and a
WiFi transceiver.

Its cost was about 7 CAD, making it a
perfect tool for makers.

Since then, many boards based on
the ESP8266 chips were developed.
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ESP8266

NodeMCU Wemos D1 Mini

Arduino UNO WiFi Workshop 8



NodeMCU

Pinout
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NodeMCU
Prepare the Arduino IDE ©

Preferences

Settings  Network

Go to File -> Preferences i

Ci'\Wsers\TrailBlazer \Documents\Arduing Browse

Editor language: System Default + | (requires restart of Arduinc)
Paste in Additional Boards Edtor fontsze: 2

. Interface scale: [ Automatic = 100 % % (requires restart of Arduino)

Manager URLS Theme: Default theme - (requires restart of Arduing)

Show verbose output during: /] compilation [ upload
http://arduino.esp8266.com/stabl el .

. . ¥ 5

e/package_esp8266com_index.js [ Yty code afer upoad [ e el e
on [ Check for updates on startup

Save when verifying or uploading

[] Use accessibility features

(Make sure your laptop is connected to
the internet)
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NodeMCU

Prepare the Arduino IDE
@

File Edit Sketch Tools Help

by ESP8266 Com|

Boards included itk Lage:
| &ric ESPE285 Module, ESPDuine (ESP-13 Module), Adafruit Feather HUZZAH ESPE2E6, Invent One,
G O to Tools -> Boa rd -> Boa rd | XinaBox CWO1, ESP'@JLO, ESPresso Lite 2.0, Phoenix 1.0, Phoanix 2.0, NodaMCU 0.9 (ESP-12 Modula), NodaMCU 1.0
(ESP-12E Module), Ol MOD-WIFI-ESP8266(-DEV), SparkFun ESP8266 Thing., SparkFun ESPE266 Thing Dev. SparkFun Blynk
Ma nager Board, SweetPea ESP-210, LOLIN(WEMOS) D1 R2 & mini, LOLIN(WEMOS) D1 mini Pro, LOLIN{WEMOS) D1 mini Lite, WeMos D1
R1, ESPino (ESP-12 Module), ThaiEasyElec's ESPino, Wiflnfo, Arduino, 4D Systems gen4 IoD Range, Digistump Oak, WuFudumo,
Amparka WiFi Slot. Seeed Wio Link, ESPactro Core, Schirmilabs Eduine WiFi, ITEAD Soncff. DOIT ESP-Mx Dg

Search for “esp8266” | @
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NodeMCU
Prepare the Arduino IDE

Go to Tools -> Board -> ESP8266
Boards

Select NodeMCU 1.0 ESP-12E
Module

b Format

Archive Sketch

Serial Monitor
4} Serial Plotter

5 ) -
Get Board Info

Programmer: "AVRISP mkil®

Burn Bootloader

Fix Encoding & Reload

Manage Libraries...

WiFi101 / WiFiNIMA Firmware Updaters

o] @)
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o _

Ctrl=Shift+
Ctrl+Shift+M
Ctrl+Shift+L
A
1 ESPresso Lite 1.0
3 Boards Manager... ESPresso Lite 2.0
3 i H Phoenix 1.0
I ESP8266 Boards (2.7.4) I Phoenix 2.0
e

>
@J I NodeMCU 1.0 (ESP-12E Medule)
@'Fun ESPE266 Thing
23

rkFun ESPE266 Thing Dev
SparkFun Blynk Board
SweetPea ESP-210
LOLIN(WEMOS) D1 RZ & mini
LOLIN(WEMOS) D1 mini Pro
LOLIN{WEMOS) D1 mini Lite
WeMos D1 R1
ESPinc (ESP-12 Module)
ThaiEasytlec's ESPino
Wifnfo
Arduing
4D Systems gend loD Range
Digistump Oak
WiFiduino
Amperka WiFi Slot
Seeed Wio Link
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NodeMCU

Test the board connection

#define ledpinl 2
#define ledpin2 16

void setup(){
pinMode(ledPin1, OUTPUT);
pinMode(ledPin2, OUTPUT);

}

void loop(){
digitalWrite(ledPin1, LOW);
digitalWrite(ledPin2, HIGH);
delay(1000);
digitalWrite(ledPin1, HIGH);

IAT 884 - Tangible Technology
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NodeMCU

Test the board connection
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NodeMCU

Webserver

. . e @ @ o o * o 0 @ @
.:}D .EIE -::o oooo: ..
g E nooﬁo .
Control hardware through a ‘D : B ¢ ¢ emmmemefmne |
website that runs off your § a T :’:—a: *e
NOdeMCU _‘ e @& & & 9 e @& & & 9 e @
Step 1: Connect 2 LEDS to pin DI oo DRI ol
andDz e e 0 0 0 o e 0o 0 0
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NodeMCU

Webserver

.

. o
.
s
* e

Q
* e o

L]
L ]
.
.
L]

Control hardware through a
website that runs off your
NodeMCU

e & & & 0
. ® 0 00

:

ARAAARARAR*®

Step 2: Download the code
from the wiki

® & & & 2 & 0 & 5 0 0D
® & & & 5 & 5 & 8 5 0 e

® & &5 & 5 5 5 & 0 8 s
e 8 & & 8 0 0 2 0 0 e
® & & & & & 8 & 8 8 8 8
® & & & 5 8 0 & 8 0 80
e ® & & 8 0 0 0 0 0 00
® 0 8 0 0 0 0 0 0 00

. °
. @
. o
e e
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NodeMCU

Webserver

® ® R XY RRXXY

Control hardware through a . - seee  ecesee
website that runs off your = = Wom . ..
NodeMCU :o = B ¢ ¢ o i .
= G 2esss M ossss |
Step 3: Connect the NodeMCU : 2999 s0099 oo
to your WiFi network by I aadl DODadal B
changing two lines in the code 59454 B4 B
// Replace with your network P 55933 39993 4P
credentials sell sssssMasess [os
const char* ssid = "" . e s e e e e e e oo .o

const char* password =
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NodeMCU

Webserver

.

. o
.
s
* e
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* e o
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.
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Control hardware through a
website that runs off your
NodeMCU

e & & & 0
. ® 0 00

:

ARAAARARAR*®

Step 4: Upload code to board

® & & & 2 & 0 & 5 0 0D
® & & & 5 & 5 & 8 5 0 e

® & &5 & 5 5 5 & 0 8 s
e 8 & & 8 0 0 2 0 0 e
® & & & & & 8 & 8 8 8 8
® & & & 5 8 0 & 8 0 80
e ® & & 8 0 0 0 0 0 00
® 0 8 0 0 0 0 0 0 00

. °
. @
. o
e e
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NodeMCU

Webserver

Control hardware through a
website that runs off your
NodeMCU

Step 5: Open the Serial Monitor
and set the baud rate to 115200
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€ com3 - O X
| Send
~
v
< >
Autoscroll BothML &CR «| 115200baud - Clear output
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NodeMCU

Webserver

[ 192.1681.132 x

&« C | ® 192.168.1.132 r

ESP8266 Web Server

GPIO 5 - State off

Control hardware through a
website that runs off your

NodeMCU m

Step 7: Copy the IP address in GPIO 4 - State off

your browser window. m

This page is sent by the ESP8266 when
you make a request on the ESP IP

address.

Workshop 8
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NodeMCU

Welbserver
€ coms - o X
| Send
Client disconnected.
Hew Client.
GET / HITE/1l.1
Control hardware through a Host: 192.168.1.132
. Connection: keep-alive
website that runs off your Cache-Control: max-age=s
User-Agent: Mozilla/5.0 (Windows NT 10.0; Winé4; xdé4) RppleWebKEit/537.36 (EHTML, like Gecko) CH
NOdeMCU Upgrade-Insecure-Requests: 1
Loeoept: text/html, application/xhtml+xml,application/xml;q=0.%, image/webp, image/apng, ¥/ *;q=0.8
Accept-Encoding: gzip, deflate
. Accept-Language: pt-PFT,pt;g=0.%,en-U5;g=0.8,en;g9=0.7
Step 8: Look at the serial
. . . Client disconnected.
monitor to see what is going on.
Hew Client.
The ESP receives an HTTP request from a . N
new Cllent —1n th|S case, your browser' [~] Autoscroll BothNL & CR.  ~ | |115200baud Clear output
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NodeMCU
Webserver
o] — O X
D 192.168.1.132 b4
< C | @ 192.168.1.132 % @B &
Control hardware through a ESP8266 Web Server
website that runs off your GPIO 5 - State off

NodeMCU m

Step 9: Click on the button to 0T Sae o
turn GPIO 5 on. Look at the

LEDs and the serial monitor. m
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NodeMCU

Webserver
Code: // Load Wi-Fi library
Include the ESP WiFi library #include <ESP8266W1iF1.h>
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NodeMCU
Webserver
Code: . .
const char*® ssid =
insert your ssid and password const char* password = ™"
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NodeMCU

Webserver

Code:

/[ Sset web server port number to 86
Then, you set your web server to .. -
oort 80. WiFiServer server(86@

Port 80 is one of the most used port
numbers. Any Web/HTTP client, such as
a Web browser, uses port 80 to send and
receive requested Web pages from a
HTTP server.
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NodeMCU

Webserver

Code:

The following lines begin the
Wi-Fi connection, wait for a
successful connection and
prints the ESP IP address in the
Serial Monitor.

IAT 884 - Tangible Technology

// Connect to Wi-Fi network with SSID and password
Serial.print("Connecting to ")
Serial.println(ssid);
WiFi.begin(ssid, password);
while (WiFi.status() != WL _CONNECTED) {
delay(500);
Serial.print(".");

// Print local IP address and start web server
Sserial.println("");

Serial.println("WiFi connected.™);
Serial.println("IP address: ");
Serial.println(WiFi.localIP());

server.begin();

Workshop 8
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NodeMCU

Webserver

Code:

_ _ _ WiFiClient client = server.avallable
The ESP is always listening for

incoming clients.

Workshop 8



NodeMCU

Webserver

Code:

When a request is received from
a client, we'll save the incoming
data. The while loop that follows
will be running if the client stays
connected.

IAT 884 - Tangible Technology

if (client) { // If a new client connects,

g

Serial.println("New Client."); // print a message out in the serial port

String currentLine = ""; // make a String to hold incoming data from the clier
while (client.connected()) { // loop while the client's connected
if (client.available()) { // if there's bytes to read from the client,
char ¢ = client.read(); // read a byte, then
Serial.write(c); // print it out the serial monitor
header += c;
if (c == '\n") { // if the byte is a newline character
// if the current line is blank, you got two newline characters in a row.
// that's the end of the client HTTP request, so send a response:
if (currentLine.length() == @) {
// HTTP headers always start with a response code (e.g. HTTP/1.1 208 OK)
// and a content-type so the client knows what's coming, then a blank line:
client.println("HTTP/1.1 260 OK");
client.println("cContent-type:text/html");
client.println("Connection: close");
client.println();

Workshop 8



NodeMCU

Webserver

Code:

When a request is received from
a client, we'll save the incoming
data. The while loop that follows
will be running if the client stays
connected.
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if (client) { // If a new client connects,

g

Serial.println("New Client."); // print a message out in the serial port

String currentLine = ""; // make a String to hold incoming data from the clier
while (client.connected()) { // loop while the client's connected
if (client.available()) { // if there's bytes to read from the client,
char ¢ = client.read(); // read a byte, then
Serial.write(c); // print it out the serial monitor
header += c;
if (c == '\n") { // if the byte is a newline character
// if the current line is blank, you got two newline characters in a row.
// that's the end of the client HTTP request, so send a response:
if (currentLine.length() == @) {
// HTTP headers always start with a response code (e.g. HTTP/1.1 208 OK)
// and a content-type so the client knows what's coming, then a blank line:
client.println("HTTP/1.1 260 OK");
client.println("cContent-type:text/html");
client.println("Connection: close");
client.println();
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Networking
(ESP8266)
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Networking
ESP-NOW

One ESP8266 board
sending data to another
ESP8266 board.

ESP-NOW

One-way
communication

.o
=D
D
z
e
=i o |
2N
£

Easy to implement
Send sensor readings or
ON/OFF commands
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Networking
ESP-NOW

E \N
SP"NOW ES?"NO
A “master” ESP8266
sending data to multiple
ESP8266 “slaves” ESP-NOW ESP-NOW

L
>

One “Master”

Multiple “Slaves”

Home automation
remote control

Workshop 8



IAT 884 - Tangible Technology

Networking
ESP-NOW

ESP-NOW

One ESP8266 “slave”
receiving data from
multiple “masters”

)
-

EE Esp
W
“Slave”

Multiple “Masters”

Collect data from
multiple sensor nodes
and display them
through 1 webserver
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Networking

ESP-NOW

Two boards
communicating with
each other. Each board
is a sender and receiver.

ESP-NOW

Two-way
communication
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Networking
ESP-NOW

Create a Star or Mesh

network. ESP-NOW

Workshop 8
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